Activation issues when moving an existing RW number to a 5.0 plan
Incident Report for Republic Wireless
Resolved
Our engineers have identified and resolved the issues that were preventing current members from moving an existing number to a 5.0 plan on a new account.

- If you have been waiting to activate a 5.0 plan you purchased on a new account, instructions to do so are here: https://help.republicwireless.com/hc/en-us/articles/4415592986263
- We are still working on a better process so current members can upgrade on their existing accounts. If you are unable to wait, you can upgrade by purchasing and activating your plan on a new account.

If you need assistance upgrading, please contact us by any of the methods listed at https://help.republicwireless.com/hc/en-us
Posted Feb 07, 2022 - 19:31 EST
Monitoring
Our engineers have identified the causes of the issues involving moving an existing Republic Wireless number to a 5.0 plan and have resolved many of these issues. A process is in development and undergoing rigorous testing that will allow our existing members with 1 and 2 service lines to transition to 5.0 without creating a new account, automating the number-transfer process. We appreciate your continued patience as you await the activation of your new 5.0 plan.
Posted Jan 21, 2022 - 16:28 EST
Update
Our engineers have identified the causes of the issues involving moving an existing Republic Wireless number to a 5.0 plan and have resolved about 40% of the pending number transfers. They continue to work toward a resolution for those that have not yet processed. We appreciate your continued patience as you await the activation of your new 5.0 plan. Existing members who have been waiting to *begin* the activation process are advised to monitor our separate incident update at https://status.republicwireless.com/incidents/zyfyqh9990tx before beginning a new transfer request.
Posted Jan 06, 2022 - 13:44 EST
Update
Our engineers have identified the causes of the issues involving moving an existing Republic Wireless number to a 5.0 plan and have resolved about 40% of the pending number transfers. They continue to work toward a resolution for those that have not yet processed. We appreciate your continued patience as you await the activation of your new 5.0 plan. Existing members who have been waiting to *begin* the activation process are encouraged to log in to republicwireless.com/activate on your NEW account and proceed with attention to accuracy; the top cause for porting issues has been incorrect PIN entry.
Posted Jan 05, 2022 - 12:11 EST
Update
Our engineers have identified the causes of the issues involving moving an existing Republic Wireless number to a 5.0 plan and have resolved about 40% of the pending number transfers. They continue to work toward a resolution for those that have not yet processed. We appreciate your continued patience as you await the activation of your new 5.0 plan. Existing members who have been waiting to *begin* the activation process are encouraged to log in to republicwireless.com/activate on your NEW account and proceed with attention to accuracy; the top cause for porting issues has been incorrect PIN entry.
Posted Jan 05, 2022 - 12:11 EST
Identified
Our engineers have identified the causes of the issues involving moving an existing Republic Wireless number to a 5.0 plan and have resolved about 40% of the pending number transfers. They continue to work toward a resolution for those that have not yet processed. We appreciate your continued patience as you await the activation of your new 5.0 plan. Existing members who have been waiting to *begin* the activation process are encouraged to log in to republicwireless.com/activate on your NEW account and proceed with attention to accuracy; the top cause for porting issues has been incorrect PIN entry.
Posted Dec 30, 2021 - 23:11 EST
Investigating
Our engineers are investigating reports of issues when activating a 5.0 plan with an existing Republic Wireless number. We do not currently have an estimated time of resolution. We encourage any existing member who has purchased a 5.0 plan to wait until this incident is resolved before attempting to activate the new plan with your current RW number. We apologize for the inconvenience and thank you for your extended patience as we work to resolve this issue.
Posted Dec 25, 2021 - 14:04 EST
This incident affected: Activations | Provisioning.