MMS delivery delays
Incident Report for Republic Wireless
Resolved
MMS delivery has returned to normal, and this incident has been resolved
Posted Jan 15, 2022 - 03:14 EST
Investigating
We are currently investigating MMS delivery delays on our 1.0, 2.0, and 4.0 service plans.
Posted Jan 14, 2022 - 20:58 EST
This incident affected: MMS Messages.