Delay to Shipping Confirmation E-mails
Incident Report for Republic Wireless
Resolved
The delay to shipping e-mails has been resolved.
Posted Mar 21, 2022 - 15:34 EDT
Identified
Shipping Confirmation E-mails: When an order is shipped, there is currently a delay before the shipping confirmation e-mail is sent. You may receive your order before you receive the tracking number. Our engineers are investigating this issue. Thank you for your patience as you await your order, and we apologize for the inconvenience. As an alternative option, our shippers offer shipment tracking and management tools that can provide you with alerts when an order ships to your address. See USPS for Informed Delivery and UPS for UPS My Choice.
Posted Jan 05, 2022 - 12:23 EST
This incident affected: Online Store.